1с создание договора контрагента программно

Содержание
  1. Как программно создать договор контрагента.
  2. 1С 8.3 Создать основной договор — Программист 1С Минск. Автоматизация бизнеса.
  3. 1С 8.3 Создать основной договор
  4. Ваш браузер устарел, пожалуйста обновите ваш браузер пройдя по ссылке www.microsoft.com/download
  5. Автоматическое создание договоров и установка основного договора контрагента
  6. Скачать файлы
  7. Специальные предложения
  8. См. также
  9. Заполнение контрагентов по ИНН для УТ 10.3 Промо
  10. Оптимизация размера изображений из присоединенных файлов УТ 11.4
  11. Обработки для 1С: Розница по работе с ЕГАИС
  12. Загрузка данных из табличного документа (поддержка дополнительных реквизитов, контактной информации)
  13. Загрузка данных из Excel (из табличного документа) в часто используемые объекты: в справочники, документы, их табличные части, в планы видов расчетов, регистры расчета, регистры сведений Промо
  14. 1С: Розница/УТ 10.3. ЕГАИС, загрузка акцизных марок в справочник Штрихкоды и Упаковки, регистр Акцизные марки из XML-сообщений входящих ТТН ЕГАИС + Печать акцизных марок
  15. Универсальный инструмент для переноса данных через табличный документ (УФ)
  16. Встраиваемая подсистема «Универсальные шаблоны объектов»
  17. Пометка на удаление неиспользуемых элементов справочников и документов Промо
  18. Автоматическое заполнение графиков в ЗУП 3.1
  19. Добавление возможности в конфигурации ЗУП 3.1 работать с фотографиями сотрудников (Зарплата и Управление Персоналом, редакция 3.1)
  20. Загрузка номенклатуры в базу «Управление торговлей 11.4, 11.5», с возможностью создания номенклатуры поставщика, через табличный документ Excel, Word
  21. Правильные аналоги номенклатуры (кроссы запчастей) для 1С / Управляемые формы Промо
  22. 2 в 1: Проверить действительность паспорта / Получить ИНН по паспорту
  23. Загрузка из ГИС ЖКХ ИД домов/зданий, Лицевых счетов, приборов учета/счетчиков в 1С ЖКХ
  24. [РАСШИРЕНИЕ] Заполнение данных контрагента по ИНН в 1С: Бухгалтерия и 1С: УНФ
  25. Прыг-Скок. или из MS EXCEL в 1С (8.2) (открытый код) Промо
  26. [Расширение] Контекстная подсказка и автозаполнение данных используя DaData.ru без снятия с поддержки БП + УТ + CRM
  27. Перенос данных. Правила конвертации из УТ 10.3 в УТ 11.4
  28. Создание номенклатуры по штрихкоду (https://barcodes.olegon.ru)
  29. Автоматическое создание Контрагентов из Физических лиц Промо
  30. Редактирование цен и остатков в карточке номенклатуры для 1С: Розница
  31. Загрузка дополнительных реквизитов и сведений справочника Номенклатура из Excel и таблиц УТ 11, ERP 2
  32. Расширенный подбор товаров [Расширение]
  33. Изменение реквизитов справочников, документов, табличных частей, движений (Обычные и Управляемые формы) Промо
  34. Получение информации о Контрагенте с использованием DADATA.ru через ПреобразованиеXSL (обычные и управляемые формы)
  35. Определение ИНН Сотрудника (service.nalog.ru). ЗУП, редакция 3.1 и 2.5 (Проф и Корп)
  36. Универсальные обработки документов, справочников, регистров, констант для 1С: Предприятие 8.3, управляемые формы

Как программно создать договор контрагента.

Первый раз пишу в 1Cv8.
Импортирую контрагентов из excel. Надо записать договор, взял из формы справочника процедуру.

Процедура ПроверитьОсновнойДоговорКонтрагента(Контрагент, НовыйОсновнойДоговорУказан)

НайденныйДоговорОбъект = Справочники.ДоговорыКонтрагентов.СоздатьЭлемент();
НайденныйДоговорОбъект.Наименование = «Основной договор»;

НайденныйДоговорОбъект.ВедениеВзаиморасчетов = ПолучитьЗначениеПоУмолчанию(глТекущийПользователь, «ОсновноеВедениеВзаиморасчетовПоДоговорам»);
Если ЗначениеНеЗаполнено(НайденныйДоговорОбъект.ВедениеВзаиморасчетов) Тогда
НайденныйДоговорОбъект.ВедениеВзаиморасчетов = Перечисления.ВедениеВзаиморасчетовПоДоговорам.ПоЗаказам;
КонецЕсли;

НайденныйДоговорОбъект.ВалютаВзаиморасчетов = ПолучитьЗначениеПоУмолчанию(глТекущийПользователь, «ОсновнаяВалютаВзаиморасчетов»);
Если ЗначениеНеЗаполнено(НайденныйДоговорОбъект.ВалютаВзаиморасчетов) Тогда
НайденныйДоговорОбъект.ВалютаВзаиморасчетов = Константы.ВалютаУправленческогоУчета.Получить();
КонецЕсли;

НайденныйДоговорОбъект.Организация = ПолучитьЗначениеПоУмолчанию(глТекущийПользователь, «ОсновнаяОрганизация»);
Если ЗначениеНеЗаполнено(НайденныйДоговорОбъект.Организация) Тогда
Выборка = Справочники.Организации.Выбрать();
Если Выборка.Следующий() Тогда
НайденныйДоговорОбъект.Организация = Выборка.Ссылка;
КонецЕсли;
КонецЕсли;

НайденныйДоговорОбъект.Владелец = Контрагент;
НайденныйДоговорОбъект.ВидУсловийДоговора = Перечисления.ВидыУсловийДоговоровВзаиморасчетов.БезДополнительныхУсловий;

Если Контрагент.Покупатель Тогда
НайденныйДоговорОбъект.ВидДоговора = Перечисления.ВидыДоговоровКонтрагентов.СПокупателем;
НайденныйДоговорОбъект.ТипЦен = Справочники.ТипыЦенНоменклатуры.ПустаяСсылка();
ИначеЕсли Контрагент.Поставщик Тогда
НайденныйДоговорОбъект.ВидДоговора = Перечисления.ВидыДоговоровКонтрагентов.СПоставщиком;
НайденныйДоговорОбъект.ТипЦен = Справочники.ТипыЦенНоменклатурыКонтрагентов.ПустаяСсылка();
Иначе
НайденныйДоговорОбъект.ВидДоговора = Перечисления.ВидыДоговоровКонтрагентов.Прочее;
КонецЕсли;

НайденныйДоговорОбъект.Записать();
. /////////////////////ОШИБКА:Вид договора «С поставщиком» может устанавливаться только когда у контрагента указано что он является поставщиком.
. ////////////////////////////////////////
ОсновнойДоговорКонтрагента = НайденныйДоговорОбъект.Ссылка;
НовыйОсновнойДоговорУказан = Истина;

Записываю элемент так:

НовыйКонтрагент=Справочники.Контрагенты.СоздатьЭлемент();
НовыйКонтрагент.Родитель=Родитель;
НовыйКонтрагент.Наименование=Зн;
НовыйКонтрагент.НаименованиеПолное=Зн;
НовыйКонтрагент.ЮрФизЛицо=Перечисления.ЮрФизЛицо.ЮрЛицо;
НовыйКонтрагент.Поставщик=Истина;
НовыйКонтрагент.НаименованиеПолное=Зн;
НовыйКонтрагент.Записать();
Состояние(«Записано «+Ы+» Контрагентов»);

НовыйОсновнойДоговорУказан = Ложь;
ПроверитьОсновнойДоговорКонтрагента(НовыйКонтрагент, НовыйОсновнойДоговорУказан);

Происходит ошибка: Вид договора «С поставщиком» может устанавливаться только когда у контрагента указано что он является поставщиком.
в процедуре ПередЗаписью() формы справочника.
Как это правильно сделать?
Заранее спасибо.

Источник

1С 8.3 Создать основной договор — Программист 1С Минск. Автоматизация бизнеса.

1С 8.3 Создать основной договор

Функция СоздатьОснДоговорБП ( Организация , Контрагент , ВидДоговора , СделатьОсновным =Ложь) Экспорт

Читайте также:  Закупки если уклонился от заключения договора

Дог = Справочники . ДоговорыКонтрагентов . СоздатьЭлемент ();
Дог . Организация = Организация ;
Дог . Владелец = Контрагент ;
Дог . ВидДоговора = ВидДоговора ;
Дог . ВалютаВзаиморасчетов = Константы . ВалютаРегламентированногоУчета . Получить ();
Дог . Наименование = ВидДоговора ;

Попытка
Дог . Записать ();
Исключение
ТекстОшибки = СтрШаблон ( «Не удалось сохранить новый договор для контрагента %1
|по виду договора %2 для организации %3″ , Контрагент , ВидДоговора , Организация );
ОбщегоНазначенияКлиентСервер . СообщитьПользователю ( ТекстОшибки );
Возврат Справочники . ДоговорыКонтрагентов . ПустаяСсылка ();
КонецПопытки;

Если СделатьОсновным Тогда
Параметры = ОбщегоНазначения . ЗначенияРеквизитовОбъекта ( Дог . Ссылка , «Организация, ВидДоговора, Владелец» );
ЗаписьРС = РегистрыСведений . ОсновныеДоговорыКонтрагента . СоздатьМенеджерЗаписи ();
ЗаписьРС . Организация = Параметры . Организация ;
ЗаписьРС . Контрагент = Параметры . Владелец ;
ЗаписьРС . ВидДоговора = Параметры . ВидДоговора ;
ЗаписьРС . Договор = Дог ;

Попытка
ЗаписьРС . Записать (Истина);
Исключение
ТекстОшибки = СтрШаблон ( «Не удалось указать договор %1 основным для контрагента %2» , Дог , Контрагент );
ОбщегоНазначенияКлиентСервер . СообщитьПользователю ( ТекстОшибки );
КонецПопытки;
КонецЕсли;

Источник

Ваш браузер устарел, пожалуйста обновите ваш браузер пройдя по ссылке www.microsoft.com/download

Автоматическое создание договоров и установка основного договора контрагента

Бывают ситуации, когда после переноса данных, либо по другим причинам, у контрагентов не назначен основной договор или вообще отсутствуют договоры.

Данная обработка автоматически создаст не существующие договоры и назначит основной договор у контрагентов.

Если в обработке указано, что нужно создавать отсутствующие договоры, то анализируются значения реквизитов контрагента «Покупатель», «Поставщик», и договоры создаются с соответствующими видами, если контрагент и не покупатель, и не поставщик, то создается «Прочий» договор. Наименования договорам присваиваются также по видам: «С покупателем», «С поставщиком», «Прочее», другие реквизиты заполняются из настроек пользователя. Далее назначается основной договор по следующим приоритетам:

т.е. если контрагент и покупатель, и поставщик, основным будет назначен договор с покупателем.

Писалась для УТ 10.3.

Скачать файлы

Специальные предложения

Обновление 05.12.14 09:56

Код открыт Не указано

См. также

Заполнение контрагентов по ИНН для УТ 10.3 Промо

Заполнение контрагентов по ИНН (1С: Управление торговлей 10.3).

17.05.2022 2142 26 kostyan7 4

Оптимизация размера изображений из присоединенных файлов УТ 11.4

У нас часто возникала ситуация, когда необходимо настроить обмен с сайтом или с внешней системой, но выгружаемые изображения слишком сильно увеличивали объем сообщений обмена, обмен происходил медленно. Да и для самой базы, операции с не оптимизированными изображениями требуют большего количество ресурсов и места на диске. Потому мы собрали свои наработки в одно расширение.

10.07.2020 12948 20 Neti 5

Обработки для 1С: Розница по работе с ЕГАИС

Несколько простых и нужных обработок для упрощения работы с ЕГАИС в 1С Розница версий 2.2.10.ХХХ и выше.

25.02.2019 31085 61 independ 15

Загрузка данных из табличного документа (поддержка дополнительных реквизитов, контактной информации)

Возможность загрузки дополнительных реквизитов, контактной информации (адрес, телефон и т.д.)

14.02.2019 19914 347 spec8s 75

Загрузка данных из Excel (из табличного документа) в часто используемые объекты: в справочники, документы, их табличные части, в планы видов расчетов, регистры расчета, регистры сведений Промо

Это перепиленная вдоль и поперек версия всем известной обработки «Загрузка из табличного документа» с диска ИТС. Добавлена возможность грузить в документы, виды расчетов, регистры расчета.

25.06.2014 16138 32 Дмитрий74Чел 7

1С: Розница/УТ 10.3. ЕГАИС, загрузка акцизных марок в справочник Штрихкоды и Упаковки, регистр Акцизные марки из XML-сообщений входящих ТТН ЕГАИС + Печать акцизных марок

Пакетная загрузка/обновление списка акцизных марок ЕГАИС из входящих ТТН ЕГАИС. Для 1С Розница 2.2.9.ХХХ/2.2.10.ХХХ//2.2.11.ХХХ/2.2.12.ХХХ/Управление торговлей 10.3.49.ХХХХ и выше с возможностью печати

31.01.2019 40702 238 independ 140

Универсальный инструмент для переноса данных через табличный документ (УФ)

Для опытных пользователей, разработчиков, администраторов, консультантов

15.10.2018 53162 172 json 44

Встраиваемая подсистема «Универсальные шаблоны объектов»

Очень часто бывает так, что пользователь каждый месяц делает какие-либо «одинаковые» операции, например, заводит одни и те же документы, каждый раз меняя в них только значения нескольких реквизитов. Также во многих системах набирают популярность так называемые многофункциональные документы, т.е. документы, отвечающие за несколько разных участков автоматизации и в зависимости от вида операции, заполняющихся по разному. Для автоматизации подобных процессов была реализована данная подсистема.

17.05.2018 25054 35 Skin123 14

Пометка на удаление неиспользуемых элементов справочников и документов Промо

В ходе работы в программе в ней зачастую накапливается «мусор». Данная разработка может помочь убрать его. (обычные или управляемые формы)

02.02.2010 46597 739 AnryMc 53

Автоматическое заполнение графиков в ЗУП 3.1

Данная разработка будет актуальна для организаций с большим количеством графиков (несколько десятков/сотен).

05.05.2018 36580 21 notserioussam 2

Добавление возможности в конфигурации ЗУП 3.1 работать с фотографиями сотрудников (Зарплата и Управление Персоналом, редакция 3.1)

Добавление возможности в ЗУП 3.1 работать с фотографиями сотрудников (физических лиц). Расширение тестировалось на релизе ЗУП 3.1.5.129.

09.04.2018 43251 87 charivnick 4

Загрузка номенклатуры в базу «Управление торговлей 11.4, 11.5», с возможностью создания номенклатуры поставщика, через табличный документ Excel, Word

Хочу поделиться простой обработкой, дающей возможность загружать номенклатуру с возможностью создания номенклатуры поставщика, в какую-либо определённую группу товаров.

15.03.2018 57832 575 appolon321 108

Правильные аналоги номенклатуры (кроссы запчастей) для 1С / Управляемые формы Промо

По опыту работы с запчастями много раз сталкивался с проблемой организации кроссов в разных 1С — от записи артикулов через запятую в текстовом поле до хранения кроссов в документах. Предлагаю одну из простейших и функциональных на мой взгляд схем «одноуровневого» хранения кроссов.

29.07.2015 53529 7 taurus__ 25

2 в 1: Проверить действительность паспорта / Получить ИНН по паспорту

Представляю вашему вниманию внешнюю обработку заполнения элемента справочника «Физические лица». Обработка выполнена с использованием API (для работы необходим доступ в интернет), содержит полностью открытый код и 2 команды: Проверка документа, удостоверяющего личность, в списке недействительных паспортов и Заполнение ИНН по паспортным данным.

27.02.2018 32711 201 VladimirElohov 40

Загрузка из ГИС ЖКХ ИД домов/зданий, Лицевых счетов, приборов учета/счетчиков в 1С ЖКХ

Загрузка из сайта ГИС ЖКХ идентификаторов ЖКУ(ИД) домов/зданий, Лицевых счетов, приборов учета/счетчиков в 1С ЖКХ

10.02.2018 38140 43 hachaturov 0

[РАСШИРЕНИЕ] Заполнение данных контрагента по ИНН в 1С: Бухгалтерия и 1С: УНФ

Бесплатное заполнение реквизитов контрагентов в 1С: Бухгалтерия, 1С: УНФ на базе сервиса dadata.ru. Добавляет кнопку заполнения по ИНН в карточку нового контрагента, не требует подписки на ИТС.

09.01.2018 58850 319 Anton64 93

Прыг-Скок. или из MS EXCEL в 1С (8.2) (открытый код) Промо

Универсальная загрузка данных из Microsoft Office Excel. Автоматическая загрузка из любых по форме документов с очень удобным редактором. Почти готовый шаблон для любой конфигурации. Не требует регистрации-бесплатно.

16.09.2015 79108 372 Tatitutu 50

[Расширение] Контекстная подсказка и автозаполнение данных используя DaData.ru без снятия с поддержки БП + УТ + CRM

Удобно искать, выбирать варианты и заполнять справочники Контрагенты\партнеры\адреса по частям строк, адресов, ИНН, чему угодно, благодаря сервису DaData.ru. Подключается в режиме Предприятие, конфигурация полностью остаётся на поддержке. Не требует наличия подписки ИТС и загрузки КЛАДРа (ФИАС) в базу, при этом не отключает штатный функционал по автозаполнению.

07.01.2018 24061 172 ipetrochenko 112

Перенос данных. Правила конвертации из УТ 10.3 в УТ 11.4

Правила конвертации из УТ10.3(10.3.32.2) в УТ11.4(11.4.1.261) (для переноса остатков, справочников)

02.01.2018 77060 608 appolon321 67

Создание номенклатуры по штрихкоду (https://barcodes.olegon.ru)

Быстрое создание номенклатуры по базе сайта https://barcodes.olegon.ru). Для 1С Розницы 2.2.ХХХ, Управление торговлей 10.3

11.09.2017 30167 70 independ 7

Автоматическое создание Контрагентов из Физических лиц Промо

Добрый день! Обработка из справочника «Физические лица» создает новый элемент справочника «Контрагенты».

28.11.2012 12608 55 hachaturov 3

Редактирование цен и остатков в карточке номенклатуры для 1С: Розница

Возможность быстрого изменения цен и остатков номенклатуры непосредственно в форме справочника. Работает на 1С: Рознице, начиная с 2.2.2.ххх

18.08.2017 25894 36 independ 7

Загрузка дополнительных реквизитов и сведений справочника Номенклатура из Excel и таблиц УТ 11, ERP 2

Внешняя обработка «Загрузка дополнительных реквизитов и сведений справочника Номенклатура»

07.08.2017 59849 374 Windyhead 45

Расширенный подбор товаров [Расширение]

Расширенные возможности подбора товаров. Отображаются цены и свободные остатки, доступен переход к ожидаемым поступлениям и информация по складам.

31.07.2017 44586 206 mrXoxot 137

Изменение реквизитов справочников, документов, табличных частей, движений (Обычные и Управляемые формы) Промо

Обработка позволяет редактировать реквизиты справочника, документа, его табличные части и движения.

15.10.2012 60376 498 Exit_in 42

Получение информации о Контрагенте с использованием DADATA.ru через ПреобразованиеXSL (обычные и управляемые формы)

Получение информации Контрагента по ИНН или Наименованию с использованием подсказок сервиса https://dadata.ru/ и разбор результата по в табличную часть: ИНН, КПП, ОГРН и ФИО руководителя организации (до кодов ФИАС/КЛАДР, координат здания включительно) и выводом результата в печатную форму. Обработка сделана для управляемых и обычных форм.

25.05.2017 21795 119 olegmedvedev 24

Определение ИНН Сотрудника (service.nalog.ru). ЗУП, редакция 3.1 и 2.5 (Проф и Корп)

Внешняя печатная форма для справочника «Сотрудники организаций». ЗУП, редакция 3.1 и 2.5 (Проф и Корп)

03.02.2017 83358 53 Indgo 34

Универсальные обработки документов, справочников, регистров, констант для 1С: Предприятие 8.3, управляемые формы

Универсальная обработка документов для любой конфигурации 1С Предприятие 8.3 на управляемых формах. Позволяет посмотреть/изменить/удалить значения реквизитов шапки/ТЧ документов. Изменить время, сформировать копии выбранных документов. Перенумеровать, пометить на удаление (снять пометку), провести (отменить проведение) выбранные документы. Если конфигурация включает БСП, будут доступны печатные формы, установленные для выбранного вида документов. Выгрузка выбранных документов в файлы *.dbf и *.xml. Универсальная обработка справочников для любой конфигурации 1С Предприятие 8.3 на управляемых формах. Позволяет посмотреть/изменить/удалить значения реквизитов элементов/ТЧ справочников. Найти ссылки на выбранные элементы. Пометить на удаление, снять пометку у объектов, провести, распровести документы по найденным ссылкам. Поиск дублей по выбранному реквизиту. Выгрузка выбранных элементов в файлы *.dbf и *.xml. Универсальная обработка регистров для любой конфигурации 1С Предприятие 8.3 на управляемых формах. Позволяет посмотреть/изменить значения регистров сведений, накопления, расчета и бухгалтерии. Удалить записи независимых регистров сведений. Перепровести документы-регистраторы, отменить проведение документов-регистраторов. Универсальная обработка констант для любой конфигурации 1С Предприятие 8.3 на управляемых формах. Позволяет посмотреть/изменить значения констант, параметров сеанса. Просмотреть все перечисления конфигурации и их значения. Найти ссылки на выбранные значения перечисления. При наличии в конфигурации механизма дополнительных отчетов и обработок из БСП, обработки можно подключить через него. Во всех обработках реализован просмотр структуры хранения данных (имена таблиц, полей) в СУБД. Во всех обработках реализован просмотр функциональных опций, связанных с соответствующими объектами и реквизитами. И их включение/выключение.

23.11.2016 35914 661 SanchoD 44

Источник

Читайте также:  Договор займа между юридическими лицами обязательные условия
Поделиться с друзьями
МальтаВиста
Наименование Файл Версия Размер